Email account provider outage

Incident Report for HOA Express

Resolved

The outage is now resolved.
Posted Oct 08, 2025 - 15:21 CDT

Monitoring

Based on our internal monitoring tools, our email account provider appears to have resolved their outage. We’re continuing to keep an eye on the situation.
Posted Oct 08, 2025 - 14:57 CDT

Identified

Our email account provider appears to be experiencing a significant outage, impacting the ability for our platform to retrieve data from their system and preventing the webmail interface from loading for some users. We’ve notified their team and are monitoring the situation closely.
Posted Oct 08, 2025 - 14:02 CDT
This incident affected: Third parties.