Elevated bounce rate for community-branded email accounts

Incident Report for HOA Express

Update

Our email account provider is continuing to work with Yahoo to resolve the issue.
Posted Sep 18, 2026 - 07:08 CDT

Investigating

Our email account provider, which powers community-branded email accounts, appears to be experiencing elevated bounce rates when sending to Yahoo-managed email addresses (predominantly Yahoo, AOL, and AT&T recipients). We have alerted our email account provider’s team and will work with them as needed on a resolution.

This issue only impacts community-branded email accounts and does not affect emails sent by our platform, including blast emails, notifications, etc.
Posted Sep 17, 2026 - 16:50 CDT
This incident affects: Third parties.